Introduction to LabVIEW and Temperature Measurement

Objective

This lab is intended to familiarize you with the LABVIEW software, the data acquisition hardware used in this class and with temperature measurements using thermocouples. No report has to be written. However, your effort will be judged by the instructor and counts towards class participation.

At the end of this lab you will understand, how a thermocouple is used to measure temperature, how cold junction compensation works and how the data is recorded and displayed using data acquisition hardware and LabVIEW software. You will also understand how signals can be both recorded and generated with a National Instruments NlcDAQ-9178 for multiple I/O DAQ (Data Acquisition) modules.

Whenever you see this symbol, write the answer to the question into the lab notebook. Use full sentences and illustrations (where applicable) to answer all questions. Use the appropriate letter to label each response.

Apparatus

1. Personal computer with LABVIEW software
2. National Instruments NlcDAQ-9178 (Compact DAQ)
3. Thermocouples
4. Circuit board with light bulb and fan

GETTING TO KNOW THE DATA ACQUISITION HARDWARE

- The data acquisition (cDAQ-9178) is an eight slot self-contained Chassis unit designed for multiple I/O DAQ modules. Notice the unit communicates with the LabVIEW software through a USB connection located in the back of the computer.
Open the LabVIEW software. Open Tools → Measurement & Automation Explorer. On the left side, click the arrows to expand: My System → Devices and Interfaces → NI cDAQ-9178. **Five modules should be listed.** These modules are automatically detected by the software. **Observe that these modules are physically present in the chassis.**

Pull up the manuals for the data acquisition chassis and modules from the class web-site (http://gozips.uakron.edu/~dorfi). You can also access these from the software by right clicking on an individual module and selecting Help → Online Device Documentation. The help documentation built into the software can also be useful. To find this click the Help tab on the top and then Help Topics → NI-DAXmx → NI-DAXmx Help. To navigate the help topics, click to expand the boxes next to the appropriate topics under the contents tab in the left pane. Based on the manuals and help documentation, answer the questions below:

- How many **analog input** modules are present?  
  - If there are multiple modules, name each and state the difference between them.
  - How many single ended channels does NI 9205 have?  
  - How many differential channels does NI 9205 have?  
    - What is the difference between single ended and differential (besides the number of channels)?  
  - What is the maximum sampling rate (look for the analog to digital conversion time) for the NI 9205 module in samples per second?

- How many **analog output** modules are present?  
  - How many analog output channels are there?

- How many **digital input** modules are present?  
  - How many digital input channels are there?

- How many **digital output** modules are present?  
  - How many digital output channels are there?

- When would you use analog input, analog output, digital input and digital output? Give examples.

- What is the number of bits used in the Analog to Digital Conversion for the NI 9205?
- What is the number of bits used in the Analog to Digital Conversion for the NI9219?
- What are the allowable voltage ranges for analog input module NI 9205 and NI9219?

- What is Cold Junction Compensation (CJC)?  
  (NI-DAXmx Help: Measurement Fundamentals → Common Sensors → Overview of Temperature Sensor Types → Thermocouples → Signal Conditioning Requirements)
  - How is Cold Junction Compensation accomplished?  
    - Where is CJC accomplished in the NIc DAQ system?
o Which module can be used for thermocouple measurements and what is built into this module that makes this possible?

• What does FS (Floating Source) - GS (Ground Source) represent?
  (NI-DAXmx Help: Measurement Fundamentals → Signal Types → Analog Connection Considerations → Connecting Analog Input Signals → Floating/Grounded Signal Sources)

• What does AI5 stand for, what does AO0 stand for?

• Open the device pinout for the NI 9219 (Right click on NI 9219 and select Device Pinouts). Look at which terminals are physical wired in the 9219 module in front of you. Draw your own diagram labeling these terminals and the respective channel.

• Compare the device pinout with your diagram to determine:
  o Which channel is wired for a thermocouple?
  o Which channel is wired for a half-bridge strain gauge?

Confirm your answers with the TA. Discuss any open questions you may have!

DATA ACQUISITION WITH THERMOCOUPLE

The next objective is to build a simple data acquisition system, which can be used to measure temperature with a thermocouple.

Simple Temperature Experiment

1. Assemble hardware
   Connect a K-type thermocouple to the thermocouple connector on the junction board.

2. Write a simple data acquisition program

   2.1 Start the LabVIEW program.
       You should see a screen similar to the one on the right.

   2.2 We want to write a new “Virtual Instrument” or VI. Therefore click on “Blank VI”. At this point, you will have two windows, a block diagram and a front panel. The front panel will display the “GUI” part of the program and the block diagram shows the logic of the instrument.

   2.3 Click on the block diagram or use Ctrl-E to switch to the block diagram window. Right click in the block diagram window, select Express → Inputs → DAQ Assist. This will place a new DAQ block into the block diagram. After a few seconds the DAQ assistant appears (as shown on the right). We want to record temperature, which is an analog input signal. Therefore select Acquire Signals → Analog
Input → Temperature → Thermocouple. The system will analyze which input channels support thermocouples. Since thermocouples produce an electric voltage, any analog in channel could be used. Select the channel that you determined was wired for a thermocouple and press Finish.

2.4 You should now see a window similar to the right. We need to tell the software a few more settings: what kind of thermocouple, what is the temperature range and units and how is CJC (cold junction compensation) done.

2.4.1. The default temperature range of 0 to 100 °F is okay. Select K Type thermocouple.
2.4.2. The CJC source is built into each channel of the module, so select built in.
2.4.3. Under the Device tab change the ADC Timing mode to **High Speed**.

2.5 Task Settings refers to how often the software asks the board for an update on the temperature. Select **Continuous Samples** at a rate of 100 samples at 100Hz (or samples/sec). That means that the software requests 100 samples every second and does that continuously. While continuously sampling, the Samples to Read value is the buffer size. The buffer size indicates the number of samples that will be stored in the computer memory. Set this value to 100 as well. Select Ok. The VI will now be configured.

2.6 Due to selecting continuous sampling, a prompt will now ask to place the VI in a loop. Select Yes.

2.7 **Add a Chart**: Select the Front Panel Window or use Ctrl-E to switch to it. Right Click on the window, select Graph → Waveform Chart. Click on the window to place the chart, adjust its size and location as needed. Double click the text “Waveform Chart” and replace it by “Temperature Chart”. Double click the text “Amplitude” and replace it by “deg F”. The Front Panel should now look as the figure to the right.
2.8 **Add a temperature indicator:** Right click in an empty area of the front panel and select Numeric → **Numeric Indicator** from the menu. Click to place the indicator. Double click on “Numeric” and replace it with “Temperature”. Now the front panel should similar to the one on the right.

2.9 **Wire the data into the indicator and temperature chart:** Switch to the **block diagram**. Point at the arrow next to “data” in the DAQ Assistant. The mouse changes to a wire spool. Click to connect a wire to the DAQ data output and run the wire to the temperature chart input. Repeat for the temperature indicator.

2.10 **Repeat measurement until stopped:** We need a continuous “While Loop” to repeat the data collection until it is stopped. This gives the continuous “strip chart” effect. **If you already set the VI in a loop, continue to the next step.** Otherwise, in the Block Diagram Window right click, select Express → Exec Ctrl → While Loop. Drag a rectangle around all objects in the block diagram. This indicates that everything inside the rectangle takes part in the while loop. You should have a picture as shown on the right. Notice, how a stop button was added to the front panel. The “Virtual Instrument” is ready. Save the instrument by selecting “File → Save As” and save to the desktop as “TempVI”.

2.11 **Run the VI:** Switch to the Front Panel and press the “Run icon” in the tool bar on the left or press Ctrl-R. A picture similar to the right should appear.

✍ What do you notice? Why is there so much noise? What could you do? Right click on the DAQ Assistant and select Properties. **Experiment by changing the Timing Settings and the Timing Mode.** Read the module manual to be able to explain the difference between the Timing Modes. Print a copy of the GUI panel from the Block Diagram and the temperature chart using the File → Print Window option. Clip and staple it **NEATLY** into your lab notebook.
2.12 Change Scale: Right click on the chart to turn off auto-scaling for the y-axis. Click on the top and bottom temperature labels and overwrite them with the limits 60 and 100. Scaling is now manual and set to the limits of 60-100 °F.

2.13 Measure temperature / Experiment with the VI: Use the VI to measure body temperature and temperature of objects such as next to cooling vents.

WARNING: Do not insert temperature probes into electric components. Electric shock and damage to equipment may occur.

Demonstrate your work and VI to the TA. Discuss any open questions you may have. Make sure you have a functional VI and save your work as TempVI.

✓ Check your understanding:
- What do you need to do, if you want to replace the thermocouple with one of a different type (say J to K)?
- What physical quantity is the data acquisition board measuring?
- How is this physical quantity converted to temperature?
- What would happen, if the temperature at the cold junction reference changes but the temperature sensed by the thermocouple temperature did not? Explain what quantities would change and how that would affect the measured temperature.
DATA ACQUISITION WITH THERMOCOUPLE AND HEAT SOURCE

The next step builds on the temperature VI. So far, you have learned, how to record an analog signal (Analog In). Now we will add an output signal. The data acquisition board can not only be used to record signals but it can also produce signals as output (Analog Out or Digital Out). The analog out feature is used to adjust the voltage to a light bulb through a “virtual dimmer switch” and thus adjust the heat output from the light bulb.

Temperature Adjustment with Light Bulb and Dimmer

3. Assemble hardware
   3.1 Connect a thermocouple to the thermocouple connector on the junction board, if not already assembled.

   3.2 Connect the light bulb/fan circuit board as shown in the figure below. There are four cables to connect.

   The light will be controlled by the NI-9263 module through AO0 of the junction board.

   The fan will be controlled by the NI-9472 module.
4. **Write the data acquisition program**
   
   4.1 Open the TempVI from the previous experiment. Save it as “LightBulbDimmerVI”.

   4.2 **Add an Analog Out Channel**: Go to the block diagram panel, right click inside the “while loop” container and add a DAQ assistant (Express → Input → DAQ Assist). Select Generating Signals → Analog Out → Voltage. The window on the right appears. Choose ao0, the analog out channel 0 as output. Click Finish.

   4.3 **Configure Analog Out Channel**: Set the signal output range to **0 to 5V**. This is the voltage range, which will be used to control the “dimmer” transistor. Select 1 sample on demand for task timing. Click “Ok”.

   4.4 **Review block diagram**: The block diagram should be similar to the one below with a second DAQ Assistant added. This DAQ block can now be used to provide an output voltage on Analog Out AO0.

4.5 **Add Dial to adjust output voltage**: Switch to front panel. Right click and select Numeric → Dial. Place the dial on the front panel. Double click on the word “Dial” and replace it by “Dimmer Output Voltage”. **Double click on the min and max values on the dial and set them to 0 and 5 respectively**. The Front Panel should now look similar to the one on the right.
4.6 **Wire Dial into Analog Out**: Switch back to the block diagram and run a wire from the dimmer dial to the data arrow of the DAQ assistant for analog out. The block diagram should look like the one in the figure to the right. Save your work. The VI is now ready.

4.7 **Experiment with the VI**: Start the VI by pressing Ctrl-R or clicking on the Run icon. Rotate the dial and make sure that the brightness of the light changes as you adjust the switch setting. Watch the temperature rise as the bulb heats the thermocouple.

![Block diagram of the VI](image)

Demonstrate your work and the VI to the TA. Discuss any open questions you may have! Make sure you have a functional VI and save your work as LightBulbDimmerVI.

---

### Cooling using a Fan

The purpose of this exercise is to add a cooling fan to lower the measured temperature and use a digital output to switch the fan on/off.

5. **Modify data acquisition program**
   5.1 **Save As**: Save the LightBulbDimmerVI as LightBulbDimmerAndCoolingFanVI.

   5.2 **Add a Digital Out Channel**: Add another DAQ Assist to the block diagram and configure it as Digital Line out, NI-9472, Channel 0.

   5.3 **Add a Fan Switch**: Go to the **front panel**, right click and select Boolean → **Pushbutton**. Rename it “Fan Switch”.

   5.4 **Wire the Switch to the Digital Out**: Go back to the **block diagram** and run a wire from the fan switch to the DAQ Assist block. Note that the wire appears to be broken. This is because the output from the fan switch is a Boolean, while the input to the digital out channel is a 1D Boolean array (on/off). In order to fix the wire, right click on the wire and select Insert → All Pallets → Array → Build Array. This converts the Boolean to a 1D Array. Compare your VI to the VI shown below.
5.5 Run the VI: Start the VI and press the Fan Switch. The fan should come on. Turn the light bulb on and heat the thermocouple. Turn the fan on/off and watch as the temperature changes due to the cooling effect of the thermocouple.

YOU ARE DONE
STORE ALL EQUIPMENT AND LOG OFF FROM THE COMPUTER!